[vbox-dev] VBoxPuelMain.DLL - GetLastError=126

Klaus Espenlaub klaus.espenlaub at oracle.com
Thu Mar 17 12:26:19 PDT 2011


On 17.03.2011 14:07, Ribhi Kamal wrote:
> Hi all!
>
> I compiled VirtualBox 4.0.51 from trunk then tried to install the
> extension pack only to be greeted by the following error:
> C:\bin>VBoxManage.exe extpack install
> Oracle_VM_VirtualBox_Extension_Pack-4.0.4-70112.vbox-extpack
> 0%...
> Progress state: E_FAIL
> VBoxManage.exe: error: Failed to install
> "C:\bin\Oracle_VM_VirtualBox_Extension_Pack-4.0.4-70112.vbox-extpack":
> Failed to load the main module
> ('C:\bin\ExtensionPacks\Oracle_VM_VirtualBox_Extension_Pack\win.x86\VBoxPuelMain.DLL'):
> VERR_MODULE_NOT_FOUND - GetLastError=126

The 4.0.4 extension pack isn't compatible with the current development 
version which you built.

> So I recompiled the code in debug and stepped through the code, and sure
> enough, LoadLibrary MS-function was failing to load
> VBoxPuelMain.DLL even though the path is correct.

Very plausible - I assume this is due to missing symbols. Not worth 
analyzing in detail really, as it's not really expected to work.

> Thinking that this might be an rependancy issue, I tried to pause the
> execution of vboxsvc.exe right before it tries to call LoadLibrary and
> copied all the DLLs that it needs to same location as the DLL (in the
> win.x86 folder).... but still I got the same error.
>
> Any Ideas on why that would happen? Perhaps I'm compiling the
> code incorrectly?
>
> So far, I was unable to get USB support to work, however, everything
> else seems to work fine. So any help would be greatly appreciated.

If you want to use the USB support you have to stay at 4.0.x...

Klaus

>
> Thanks in advance!
> -- RK
>
>
>
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> http://vbox.innotek.de/mailman/listinfo/vbox-dev




More information about the vbox-dev mailing list