[vbox-dev] vde support patch (it should fix http://www.virtualbox.org/ticket/7119)

Renzo Davoli renzo at cs.unibo.it
Thu Mar 17 01:50:23 PDT 2011


I did not notice this bug report (if you see that there are open problems
related to vde, please forward the news also to the vde-users mailing list).

VDE gets dynamically loaded into virtualbox if there is the support in the
hosting environment.

The error is to name the specific version of libvdeplug.
libvdeplug is implemented to be backward compatible when dynamically loaded
as the vde_open_real has a library version parameter.
When a tool using an older version of the library loads a newer library,
the library itself recognizes the mismatch and behave like the old version.

So this simple patch should solve the problem.

	renzo

----
--- include/VBox/VDEPlugSymDefs.h.orig	2011-03-17 09:33:50.000000000 +0100
+++ include/VBox/VDEPlugSymDefs.h	2011-03-17 09:34:23.000000000 +0100
@@ -1,5 +1,5 @@
 /** @file
- * Symbols from libvdeplug.so.2 to be loaded at runtime for DrvVDE.cpp
+ * Symbols from libvdeplug.so to be loaded at runtime for DrvVDE.cpp
  */
 
 /*
@@ -43,7 +43,7 @@
 };
 
 /** The file name of the DBus library */
-#define VBOX_LIB_VDE_PLUG_NAME "libvdeplug.so.2"
+#define VBOX_LIB_VDE_PLUG_NAME "libvdeplug.so"
 #define RT_RUNTIME_LOADER_LIB_NAME VBOX_LIB_VDE_PLUG_NAME
 
 /** The name of the loader function */




More information about the vbox-dev mailing list