[vbox-dev] Compiling v4.0.4 fails on openSUSE

Alexey Eromenko al4321 at gmail.com
Sun Mar 13 12:57:12 PDT 2011


On Sun, Mar 13, 2011 at 2:08 PM, Frank Mehnert <frank.mehnert at oracle.com> wrote:
> On Sunday 13 March 2011 06:27:31 Alexey Eromenko wrote:
>> Host: openSUSE 10.3, 64-bit, VBox 4.0.4.
>>
>> # ./configure --with-qt-dir=/opt/qtsdk-2010.05/qt/ --nofatal
>> #
>> ...
>> kBuild: Compiling VMMR3 -
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMPool.cpp
>> kBuild: Compiling VMMR3 -
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMSavedState
>> .cpp cc1plus: warnings being treated as errors
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMPool.cpp:
>> In function ?void pgmR3PoolWriteProtectPages(VM*)?:
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMPool.cpp:9
>> 11: warning: array subscript is above array bounds [-Warray-bounds]
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMPool.cpp:9
>> 11: warning: array subscript is above array bounds [-Warray-bounds]
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMPool.cpp:9
>> 21: warning: array subscript is above array bounds [-Warray-bounds]
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMPool.cpp:9
>> 23: warning: array subscript is above array bounds [-Warray-bounds]
>> kmk: ***
>> [/home/alexey/Linstall/VirtualBox-4.0.4_OSE/out/linux.amd64/release/obj/VM
>> MR3/VMMR3/PGMPool.o] Error 1
>> The failing command:
>> @g++ -c -O2 -g -pipe -pedantic -Wshadow -Wall -Wextra
>> -Wno-missing-field-initializers -Wno-unused -Wno-trigraphs
>> -fdiagnostics-show-option -Wno-long-long -Wno-variadic-macros -O2
>> -mtune=generic -fno-omit-frame-pointer -fno-strict-aliasing
>> -fvisibility=hidden -DVBOX_HAVE_VISIBILITY_HIDDEN
>> -DRT_USE_VISIBILITY_DEFAULT -fvisibility-inlines-hidden -fPIC -Werror
>> -m64 -I/home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/include
>> -I/home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/PATM
>> -I/home/alexey/Linstall/VirtualBox-4.0.4_OSE/include
>> -I/home/alexey/Linstall/VirtualBox-4.0.4_OSE/out/linux.amd64/release
>> -DVBOX -DVBOX_WITH_DEBUGGER -DVBOX_OSE -DVBOX_WITH_64_BITS_GUESTS
>> -DVBOX_WITH_HARDENING -DRTPATH_APP_PRIVATE=\"/opt/VirtualBox\"
>> -DRT_OS_LINUX -D_FILE_OFFSET_BITS=64 -DRT_ARCH_AMD64 -D__AMD64__
>> -DIN_RING3 -DHC_ARCH_BITS=64 -DGC_ARCH_BITS=64 -DPIC -DIN_VMM_R3
>> -DIN_DIS -DIN_GMM_R3 -DIN_DBG -DVBOX_WITH_RAW_MODE
>> -DVBOX_WITH_MULTI_CORE -DVBOX_WITH_VMMR0_DISABLE_LAPIC_NMI
>> -DVBOX_SVN_REV=70112 -DVBOX_WITH_USB -DVBOX_WITH_PDM_ASYNC_COMPLETION
>> -Wp,-MD,/home/alexey/Linstall/VirtualBox-4.0.4_OSE/out/linux.amd64/release/
>> obj/VMMR3/VMMR3/PGMPool.o.dep
>> -Wp,-MT,/home/alexey/Linstall/VirtualBox-4.0.4_OSE/out/linux.amd64/release
>> /obj/VMMR3/VMMR3/PGMPool.o -Wp,-MP -o
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/out/linux.amd64/release/obj/VMM
>> R3/VMMR3/PGMPool.o
>> /home/alexey/Linstall/VirtualBox-4.0.4_OSE/src/VBox/VMM/VMMR3/PGMPool.cpp
>> kmk: *** Waiting for unfinished jobs....
>> kmk: *** Exiting with status 2
>>
>> any ideas?
>>
>> As for dependencies, I have all, except "makeself", which I don't know
>> how-to-install. I have manually installed Qt4.7. SDK.
>
> Add
>
>  VBOX_WITH_WARNINGS_AS_ERRORS :=
>
> to your LocalConfig.kmk. The reason for this error is that obviously
> the gcc from your ancient openSUSE distribution does not support
> -Wno-array_bounds, otherwise this option would be automatically used.
>

Thanks.

> If openSUSE does not provide makeself then you have to download and
> install it manually.
>

"makeself" does not offer install script, only can unpack itself.
VBox ./configure doesn't see it.

-- 
-Alexey Eromenko "Technologov"




More information about the vbox-dev mailing list