[vbox-dev] Parallel build failure

Malte Starostik lists at malte.homeip.net
Wed Jul 27 12:38:52 PDT 2011

> > do you know which version kmk gentoo is using for building? Sounds like
> > it's not the same as we are using since we're constantly building
> > VirtualBox on multi-core/cpu boxes and are not seeing this issue.
> the Gentoo package is labelled as 0.5.5-r1 (r1 being the package revision):
> kmk - kBuild version 0.1.98 (r2274)
> Based on GNU Make 3.81.90:
> I can try some build cycles with 0.1.5_p2 tomorrow and see if that changes
> anything.

Sorry, took a little longer to collect these results.  I tried again with this 

kmk - kBuild version 0.1.5 (r2373)

Based on GNU Make 3.81.90:

and VirtualBox 4.1.0.

Testing results:

* All combinations of kmk 0.1.98 resp.0.1.5 and VirtualBox 4.0.12 resp. 4.1.0 
exhibit the same spurious build failures.

* Although the error hit me before during normal building (for VB 4.0.10 and 
4.0.12) - and both times it took more than one repetition and then going back 
to -j1 to get through the build - it wasn't all that easy to reproduce it as 

* My normal builds were passing -j3 -l3 to make/kmk.  In fact I was about to 
raise the job number on this machine, but hadn't done so yet, and this 
apparently made me select the magic values - at least for this box:
With -j3 -l3, roughly 40% of the builds fail, all of them with a missing 
I then tried with -j1, to -j4, and varying values for -l, including no -l 
option at all.  All of those combinations succeeded with a 100% rate for at 
least 10 build runs each.

All in all, this still seems like a make dependency issue to me, although I 
think it's rather weird how reproducible only one single combination of make 
options makes it bite - especially as the machine was subject to varying 
amounts of non-related load in the meantime.


More information about the vbox-dev mailing list