[vbox-dev] Regarding about the Pause function in Virtualbox SDK

John Lee skjl25 at gmail.com
Mon Jan 10 02:29:27 PST 2011

On 2011-01-10 오후 7:20, Frank Mehnert wrote:
> On Monday 10 January 2011 11:14:36 John Lee wrote:
>> On 2011-01-10 오후 7:07, Frank Mehnert wrote:
>>> On Monday 10 January 2011 10:55:49 John Lee wrote:
>>>> On 2011-01-10 오후 6:32, Frank Mehnert wrote:
>>>>> John,
>>>>> On Monday 10 January 2011 10:04:41 John Lee wrote:
>>>>>> On 2011-01-10 오후 5:45, Klaus Espenlaub wrote:
>>>>>>> On 10.01.2011 08:25, John Lee wrote:
>>>>>>>> Hello,
>>>>>>>> I'm having a problem with the Pause function within the Virtualbox
>>>>>>>> SDK 4.0.
>>>>>>>> I'm using the same code that I used to test the VM via Virtualbox
>>>>>>>> SDK 3.2 but it seems like I'm having a trouble with the
>>>>>>>> Pause/PowerDown with the new SDK.
>>>>>>>> The problem I'm facing is that whenever I call either
>>>>>>>> Pause/PowerDown while the VM is running, the application that I'm
>>>>>>>> running presents the seg fault message.
>>>>> Please have a look at the VBox.log file. Do you have sound enabled for
>>>>> that VM? Does the sound backend initialize properly or do you see any
>>>>> warnings regarding sound during initialization? You could also disable
>>>>> sound for the VM and try again. There is a known 4.0 bug which could
>>>>> lead to a SEGFAULT under these conditions.
>>>> I have disabled the sound and vice versa but somehow that didn't solve
>>>> the problem. I have tried to looked up the VBox.log file but somehow
>>>> could not locate the file.
>>>> I have also disable the virtualization acceleration in case there is a
>>>> problem but still the problem remains unsolvable.
>>>> Is there any possible way to fix the problem?
>>> The VBox.log file can be displayed by opening the VM manager window and
>>> choosing Machine / Show Log ...
>>> Does the VM also crash when you pause the VM using the GUI?
>> No, the VM does not crash. Only the source code displays the seg fault
>> message.
>> When I use the GUI, the VM pause/turns off normally. However, by using
>> the SDK, the problem is still remains.
> Hmm, but you are using the C binding, do you? In that case that might
> be the reason because AFAIR the C bindings are kind of orphaned. Could
> you check if the same crash happens if you are using the C++ bindings?
> Kind regards,
> Frank

Yes, I have used the cbinding.
I tried to compile the c++ code but it displays the message 
"VBoxXPCom.so: No such file or directory." But the specific file is 
located at /usr/lib/virtualbox in my machine.

hum, I'm sorry but is it possible that you can help me out to solve this 

Thank you.

John Lee

More information about the vbox-dev mailing list