[vbox-dev] Error creating Session instance! rc = 0x80040154

Nikolay Igotti nikolay.igotti at oracle.com
Sat Nov 6 01:44:32 PDT 2010

    Have you tried running VBox own frontend? Does it work for you?
As you probably noticed, 0x80040154 is E_CLASSNOTREG, and means class is 
not registered.
This problem may appear, if you installed 64-bit VirtualBox, and try to 
use it from 32-bit COM client, or vice versa, as 32 and 64 bit COM 
classes use different registry subtrees.
This is internal Microsoft COM limitation our team couldn't help with, 
so just use client of matching bitness (32/64 bit client/server mixing 
will work with XPCOM on other platforms,
as we have control over source code and fixed it for such usage scenario).


06.11.2010 10:01, Prometheus пишет:
> This happens every time I try to use the MSCOM bindings to use 
> VirtualBox. I'm trying to do something simple (send VM poweroff, 
> sleep, wake, etc), but no matter what I do, I keep getting this error. 
> I tried using the tlb file with C# first, but that resulted in a crash 
> at runtime. Tried using C++/CLI, then that failed as well. Finally, I 
> tried doing it via unmanaged C++ with a C++/CLI wrapper (the main app 
> is in C#). All of these spouted the same error.
> I finally resorted to building the example and enabling the test 
> poweron (changing the VM name to a valid one, of course) and it gave 
> the same error! Is the COM API broken?
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> http://vbox.innotek.de/mailman/listinfo/vbox-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20101106/b061a793/attachment-0001.html 

More information about the vbox-dev mailing list