[vbox-dev] ZETA DHCP issue (was Re: Presentation; Alt-OS devroom at FOSDEM)

François Revol revol at free.fr
Thu Jan 7 06:34:18 PST 2010


> >> Which type of networking have you used, when met problems with 
> > > DHCP? 
> >> The 
> >> logs might be helpful.
> >>     
> >
> > I was using NAT. Someone on IRC told me to try bridge mode which 
> > indeed 
> > worked when on a LAN, but it's not easily usable when you have to 
> > use a 
> > VPN over wifi...
> >   
> Do you mean http://www.virtualbox.org/ticket/5789 or issue on forum 

Not sure, but it seems quite obvious from the tcpdump:

With 3.0.12 (working):

15:20:37.247403 0.0.0.0.bootpc > 255.255.255.255.bootps:  
xid:0xeb31014c flags:0
x8000 [|bootp]
15:20:37.248434 arp who-has 255.255.255.255 (Broadcast) tell 10.0.2.2
15:20:37.248458 10.0.2.2.bootps > 255.255.255.255.bootpc:  
xid:0xeb31014c Y:10.0
.2.15 S:10.0.2.4 [|bootp] [tos 0x10]
15:20:37.395266 arp who-has 10.0.2.15 tell 10.0.2.15

With 3.1.2 (not working):

15:14:10.609098 0.0.0.0.bootpc > 255.255.255.255.bootps:  
xid:0x6435e777 flags:0
x8000 [|bootp]
15:14:10.609724 10.0.2.2.bootps > 10.0.2.15.bootpc:  xid:0x6435e777 
flags:0x8000
 Y:10.0.2.15 S:10.0.2.4 [|bootp] [tos 0x10]
15:14:13.110966 0.0.0.0.bootpc > 255.255.255.255.bootps:  
xid:0x6435e777 secs:2
flags:0x8000 [|bootp]
15:14:13.111501 10.0.2.2.bootps > 10.0.2.15.bootpc:  xid:0x6435e777 
flags:0x8000
 Y:10.0.2.15 S:10.0.2.4 [|bootp] [tos 0x10]
15:14:16.939292 0.0.0.0.bootpc > 255.255.255.255.bootps:  
xid:0x6435e777 secs:6
flags:0x8000 [|bootp]

It seems the DHCP reply is sent to the allocated IP, not to the 
broadcast address !?

The log for the (not working) 3.1.2 boot:
http://revolf.free.fr/beos/ASUS-2010-01-07-15-15-24.log

>  Could you please give me a hint how to reproduce the issue?

I tried to boot an old BeOS R5 image but it seems there are still 
issues with it (can't find boot device). I thought I had a ZETA demo CD 
I could image, but it seems broken. It might be possible to find an 
image on bittorrent though :p

François.





More information about the vbox-dev mailing list