[vbox-dev] VirtualBox Build errors on Windows

Klaus Espenlaub Klaus.Espenlaub at Sun.COM
Tue May 5 11:46:07 PDT 2009


Suren Reddy wrote:
> 
> 
> 
>     Hello:
>     I am close to building vbox sources on Windows. I spent almost a
>     week building the stuff but still no luck:)  Has anyone noticed
>     below errors?
> 
>     kBuild: Pass - Build Programs
>     kmk.exe[1]: Entering directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     kmk.exe[2]: Entering directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     kmk.exe[2]: Nothing to be done for `pass_bldprogs_doit'.
>     kmk.exe[2]: Leaving directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     kmk.exe[1]: Leaving directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     kBuild: Pass - Libraries
>     kmk.exe[1]: Entering directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     kmk.exe[2]: Entering directory
>     `C:/Vbox/VirtualBox-2.2.0_OSE/src/VBox/Devices/PC/Etherboot-src'
>     kmk.exe[2]: Nothing to be done for `pass_libraries'.
>     kmk.exe[2]: Leaving directory
>     `C:/Vbox/VirtualBox-2.2.0_OSE/src/VBox/Devices/PC/Etherboot-src'
>     kmk.exe[2]: Entering directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     kBuild: Generating
>     C:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/obj/webservice/gsoapH_from_gsoap.h
>     /bin/wsdl2h.exe 
>     -tC:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/obj/webservice/typemap.dat
>     -nvbox -o
>     C:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/obj/webservice/gsoapH_from_gsoap.h
>     C:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/bin/sdk/bindings/webservice/vboxweb.wsdl
>     kmk.exe[2]: Leaving directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     kmk.exe[1]: Leaving directory `C:/Vbox/VirtualBox-2.2.0_OSE'
>     process_begin: CreateProcess(NULL, /bin/wsdl2h.exe
>     -tC:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/obj/webservice/typemap.dat
>     -nvbox -o C:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/obj/webservi
>     ce/gsoapH_from_gsoap.h
>     C:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/bin/sdk/bindings/webservice/vboxweb.wsdl,
>     ...) failed.

This is caused by missing gSOAP configuration in configure.vbs - the 
code is pretty new in OSE, so no one thought about adding it to that 
config script. A quick workaround is disabling the webservice code 
completely, by putting

VBOX_WITH_WEBSERVICES=

in the file LocalConfig.kmk in the toplevel directory. The file doesn't 
exist initially.

This is still the case with VirtualBox 2.2.2 which has been released 
since you started...

>     make (e=3): The system cannot find the path specified.
>     kmk.exe[2]: ***
>     [C:/Vbox/VirtualBox-2.2.0_OSE/out/win.x86/release/obj/webservice/gsoapH_from_gsoap.h]
>     Error 3
>     kmk.exe[1]: *** [pass_libraries_this] Error 2
>     kmk: *** [pass_libraries_order] Error 2
> 
> 
>     -Suren

Klaus




More information about the vbox-dev mailing list