[vbox-dev] [PATCH] Enable vbox to build on FreeBSD HEAD

Bernhard Fröhlich decke at bluelife.at
Mon May 4 06:19:12 PDT 2009


On Mon, May 4, 2009 12:04 pm, Gustau Pérez wrote:
>
>   Hi,
>
>   tried your patch and your port. It compiles fine in current (svn
> didn't compile). When trying to kldload the module it fails. I tried :
>
>         kldload /boot/kernel/vboxdrv.ko
>
>   and fail with an strange error :
>
>        kldload: can't load /boot/kernel/vboxdrv.ko: No such file or
> directory
>
>   however it is there. Looking in dmesg :
>
>       link_elf: symbol unit2minor undefined

Someone already found that unit2minor was removed from current so that
needs to be patched.


>   It is strange. On the other hand there's another error. If I try to
> start VirtualBox by hand in the terminal I see it looks like
> there are some shared objects installed in the wrong place :
>
>         [root at portatil ~]# VirtualBox
>        VirtualBox: supR3HardenedVerifyFileInternal: Failed to open
> "/usr/local/share/virtualbox/VBoxRT.so": No such file or directory (2)

As a workaround you can symlink the missing shared objects to
/usr/local/lib/virtualbox

That's what i wrote yesterday. The port is under heavy development and
badly broken at the moment as i moved a few files around. So please give
us some time to fix this and bring it into proper shape. It's not working
yet but we're working on it.

-- 
Bernhard Fröhlich
http://www.bluelife.at/





More information about the vbox-dev mailing list