[vbox-dev] [PATCH] Enable vbox to build on FreeBSD HEAD

Bernhard Fröhlich decke at bluelife.at
Sun May 3 14:19:28 PDT 2009


On Sun, May 3, 2009 9:36 pm, Frank Mehnert wrote:
> On Sunday 03 May 2009, Cezary Morga wrote:
>> Bernhard Fröhlich wrote:
>> > Thanks, for the patches i've integrated it in the port we are
>> currently
>> > working on. The pmap_enter() already got MFCd in r189075 [0] so it's
>> > needed for 7-stable too and builds fine now.
>> >
>> > Progress on the port is good as it already builds on amd64 and i386 on
>> 7
>> > and current.
>>
>> Well. I couldn't run VirtualBox on my FreeBSD machine. I get:
>>
>> Unknown -102 error during initialization of the Runtime
>>
>> and when compiled with debugging symbols I get :
>>
>> !!Assertion Failed!!
>> Expression: g_szrtProcExePath[0] != '\0'
>> Location  :
>> /home/therek/svn/virtualbox/src/VBox/Runtime/r3/process.cpp(100) char*
>> RTProcGetExecutableName(char*, size_t)
>> Trace/BPT trap: 5
>
> This happens usually if you starting a debug build (assertions are
> disabled in a release build; debug builds are _much_ slower than
> release builds) and /proc is not mounted. See
>
>   src/VBox/Runtime/r3/freebsd/rtProcInitExePath-freebsd.cpp
>
> function rtProcInitExePath().
>
>> My machine:
>> FreeBSD 7.1-STABLE FreeBSD 7.1-STABLE #0: Wed Feb 25 08:48:36 CET 2009
>>
>> As for the port you're mixing two different install locations (diff
>> below).
>> You should either put VirtualBox in typical library location or add
>> ldconfig - m /usr/local/share/virtualbox.
>
> Right, the binaries should be installed to ${PREFIX}/bin not
> ${PREFIX}/sbin.

Thanks, that's fixed. But be warned that the port is badly broken at the
moment because i've moved all the files around. I'll fix it tomorrow.


>> What about kernel module?
>
> I can't speak for FreeBSD but for Linux we install the sources for the
> kernel modules usually into /usr/share/virtualbox/src or to /usr/src/

Kernel module gets now installed too. Don't know if it makes much sense to
have the source installed because we are building from source all the
time.


The current status is that Bug #3919 breaks building and starting
VirtualBox fails with:

Failed to create the VirtualBox COM object.
Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)

That's probably just a misconfiguration by me but i haven't looked closer
yet.

We also needed to patch the Qt4 frontend because includes of event classes
were missing and a few leftovers of Qt3 includes which failed when Qt3
headers were installed. I'll file separate bugreports for that.


-- 
Bernhard Fröhlich
http://www.bluelife.at/





More information about the vbox-dev mailing list