[vbox-dev] Windows 2003 sp1 checked build not working in vbox

Huihong Luo huisinro at yahoo.com
Sun Jan 25 09:24:20 PST 2009

I tried again with windbg attached, still not working, see below messages.
All other checked builds worked, so I would think something funny happening.
Microsoft (R) Windows Debugger Version 6.10.0003.233 X86
Copyright (c) Microsoft Corporation. All rights reserved.
Opened \\.\pipe\com_1
Waiting to reconnect...
Connected to Windows Server 2003 3790 x86 compatible target at (Sun Jan 25 09:07:12.314 2009 (GMT-8)), ptr64 FALSE
Kernel Debugger connection established.  (Initial Breakpoint requested)
Symbol search path is: SRV*c:\websymbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows Server 2003 Kernel Version 3790 MP (1 procs) Checked x86 compatible
Built by: 3790.srv03_sp1_rtm.050324-1447
Machine Name:
Kernel base = 0x81000000 PsLoadedModuleList = 0x8125b528
System Uptime: not available
WARNING: Whitespace at end of path element
Break instruction exception - code 80000003 (first chance)
*                                                                             *
*   You are seeing this message because you pressed either                    *
*       CTRL+C (if you run kd.exe) or,                                        *
*       CTRL+BREAK (if you run WinDBG),                                       *
*   on your debugger machine's keyboard.                                      *
*                                                                             *
*                   THIS IS NOT A BUG OR A SYSTEM CRASH                       *
*                                                                             *
* If you did not intend to break into the debugger, press the "g" key, then   *
* press the "Enter" key now.  This message might immediately reappear.  If it *
* does, press "g" and "Enter" again.                                          *
*                                                                             *
811507b4 cc              int     3
kd> g
MTRR feature disabled.
KiInitializeMTRR: OS support for MTRRs disabled
[Err ][ApphelpCacheInitialize        ] Failed to retrieve apphelp cache 0xc0000034
Sbp2Port: DriverEntry: Mar 24 2005 15:02:52
Smart Array 5x and 6x Controllers Storport Driver HpCISSs.sys Version Build 2 (x86)
STORMINI: HpCISSs:     (bit 0) 0x00 = Critical/Fatal errors = DPFLTR_ERROR_LEVEL = DEBUGPRINT Level 0.
STORMINI: HpCISSs:     (bit 1) 0x02 = Warnings = DPFLTR_WARNING_LEVEL = DEBUGPRINT Level 1.
STORMINI: HpCISSs:     (bit 2) 0x04 = Informational #1 = DPFLTR_TRACE_LEVEL = DEBUGPRINT Level 2.
STORMINI: HpCISSs:     (bit 3) 0x08 = Informational #2 = DPFLTR_INFO_LEVEL = DEBUGPRINT Level 3.
STORMINI: HpCISSs:     (bit 4) 0x10 = Function entry points = DEBUGPRINT Level 4.
STORMINI: HpCISSs:     (bit 5) 0x20 = Informational #3 = DEBUGPRINT Level 5.
STORMINI: HpCISSs:     ed Kd_IHVDRIVER_Mask 0x02 will print Critical/Fatal errors and Warnings.
STORMINI: HpCISSs:     ed Kd_IHVDRIVER_Mask 0x3E will print everything.
STORMINI: HpCISSs:     ed Kd_IHVDRIVER_Mask 0x06 recommended setting.
STORMINI: HpCISSs:     Symbols for nt module (ntkrnlmp) must be loaded to set driver debug level.
RAMDISK: CreateRegistryDisks: ZwOpenKey(2) failed: c0000034
Sbp2Port: unloading
LDR: LdrpInitializeProcess - unable to set current directory to "\"; status = c000003a
drive name: \Device\Harddisk0\Partition1
fsname: ntfs
Formatting 20465M
Creating file system structures.     
Format complete.                         
  20956760 KB total disk space.
  20890376 KB are available.
Format return code: 1
SETUP:AutoFormat Status : 0
LDR: LdrpInitializeProcess - unable to set current directory to "\"; status = c000003a
Checking file system on \Device\Harddisk0\Partition1
The volume is clean.
Windows has finished checking the disk.
SETUP: Read pagefile from txtsetup 78 fa
SETUP: Unable to open \registry\machine\system\currentcontrolset\Services\ACPI\Parameters on the setup hive (c0000034)
SETUP: Unable to open \registry\machine\system\currentcontrolset\Services\P3\Parameters on the setup hive (c0000034)
SETUP: Unable to open \registry\machine\system\currentcontrolset\Control\Processor on the setup hive (c0000034)
SETUP: Unable to read 1 sectors starting at sector 41913521
SETUP: SpIsNtfs: Error c0000011 reading sector 41913521
Shutdown occurred at (Sun Jan 25 09:19:42.565 2009 (GMT-8))...unloading all symbol tables.
WARNING: Whitespace at end of path element
Waiting to reconnect...

--- On Sun, 1/25/09, Sander van Leeuwen <Sander.Vanleeuwen at Sun.COM> wrote:

From: Sander van Leeuwen <Sander.Vanleeuwen at Sun.COM>
Subject: Re: [vbox-dev] Windows 2003 sp1 checked build not working in vbox
To: "VirtualBox developer's list" <vbox-dev at virtualbox.org>
Date: Sunday, January 25, 2009, 3:01 AM

If you don't attach a kernel debugger to checked builds, you'll never get very far.One of the drivers triggers an assertion as can be seen
from the bug check message.

Huihong Luo wrote: 

I tried a few times install Windows 2003 sp1 Enterprise Checked build into vbox, but it failed during installation. BSOD of bugcheck code of 7E appeared after 1st reboot during installation.
Technical information:
*** STOP: 0x0000007E (0x80000003, 0x81158CC1, 0xF8891D68, 0xF8891A64)
I tried the lastest version and a prior version of vbox, all failed.
You can download the OS from Microsoft MSDN subscriber download area:
iso file: en_windows_server_2003_with_sp1_enterprise_chk.iso
I tried other debug builds, 2003R2/Vista/Windows7 etc., all works fine.
Huihong Luo
vbox-dev mailing list
vbox-dev at virtualbox.org

Kind regards / Mit freundlichen Gruessen / Met vriendelijke groet


Sun Microsystems GmbH        Sander van Leeuwen
Werkstrasse 24               Senior Staff Engineer, VirtualBox
71384 Weinstadt, Germany     mailto:Sander.Vanleeuwen at sun.com

Sitz der Gesellschaft: Sun Microsystems GmbH,
Sonnenallee 1, 85551 Kirchheim-Heimstetten
Amtsgericht Muenchen: HRB 161028
Geschaeftsfuehrer: Thomas Schroeder,
Wolfgang Engels, Dr. Roland Boehmer
Vorsitzender des Aufsichtsrates: Martin Haering
vbox-dev mailing list
vbox-dev at virtualbox.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20090125/56b95cef/attachment-0001.html 

More information about the vbox-dev mailing list