[vbox-dev] Driver 'VBoxHDD' wasn't found!

Stefan Koesling lekanteto at gmail.com
Mon Feb 9 19:11:39 PST 2009


Hello Klaus, et all

thanks for the quick response. Now I get:

DrvVD: Configuration error: Querying "Format" as string failed!

Is this another VBoxBFE issue where BFE does not specify the format of the
image?


Please let me know if you need more information,
Stefan



On Mon, Feb 9, 2009 at 9:03 AM, Klaus Espenlaub <Klaus.Espenlaub at sun.com>wrote:

> Stefan Koesling wrote:
> > Hello all,
> >
> > I am trying to run run vbox ose (vboxbfe.exe) )wich I build with vc++
> > express edition with a .vdi file that was created with the closed source
> > edition.
> > I get the following error message:
> >
> > !!Assertion Failed!!
> > Expression: <none>
> > Location  : E:\VBox\trunk\src\VBox\VMM\PDMDriver.cpp(594)
> pdmR3DrvHlp_Attach
> > Driver 'VBoxHDD' wasn't found!
> >
> >
> >
> > I tried to debug and found that pDriversNode == null in pdmR3DrvInit(PVM
> > pVM)
> >     /*
> >      * Load the builtin module
> >      */
> >     PCFGMNODE pDriversNode = CFGMR3GetChild(CFGMR3GetRoot(pVM),
> > "PDM/Drivers");
> >
> >
> >
> > Is my vbox build incomplete? Do you have any ideas what could be wrong?
>
> All fine. Just VBoxBFE wasn't updated lately to take the disk image
> handling changes into account. It was just silently broken without
> anyone noticing, as VBoxBFE isn't packaged. Thanks for spotting this.
>
> VBoxHDD is the old VDI only driver, which was removed with version 2.1.
> Should be fixed now in latest trunk version.
>
>
> Thanks,
>
> Klaus
>
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> http://vbox.innotek.de/mailman/listinfo/vbox-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20090209/df8dbe1d/attachment-0001.html 


More information about the vbox-dev mailing list