[vbox-dev] CreateMachine issue with vboxwebsrv

Jean-Michel Guillaume jean-michel.guillaume at sophia.inria.fr
Thu Feb 5 05:48:02 PST 2009


Jean-Michel Guillaume a écrit :
> Klaus Espenlaub a écrit :
>> Hi,
>>
>> Jean-Michel Guillaume wrote:
>>   
>>> Hello everyone.
>>> I try to create a Machine with the VBox webservice sdk
>>>
>>> [code]
>>>        VboxServiceLocator service = new VboxServiceLocator();
>>>        VboxPortType port = service.getvboxServicePort(new 
>>> URL("http://localhost:18083/"));
>>>        String oVbox = port.IWebsessionManager_logon("","");
>>>        String machine = 
>>> port.IVirtualBox_createMachine(oVbox,"","Clone","");
>>> [/code]
>>>
>>> but get the following error:
>>>
>>> [code]
>>>    Exception in thread "main" AxisFault
>>>     faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Client
>>>     faultSubcode:
>>>     faultString: VirtualBox error: Guest OS type '' is invalid (0x80bb0001)
>>>     faultActor:
>>>     faultNode:
>>>     faultDetail:
>>>        
>>> {http://www.virtualbox.org/}RuntimeFault:<resultCode>-2135228415</resultCode><interfaceID/><component>VirtualBox</component><text>Guest 
>>> OS type '' is invalid</text>
>>> [/code]
>>>     
>>
>> This error message is perfectly clear. The empty string is invalid as a 
>> guest os type. If you don't want to specify anything in particular, use 
>> "Other".
>>
>> If you want to know the list of valid os types, there's an API for 
>> querying this.
>>
>>   
>>> from axis, and this one on the service output:
>>>
>>> [code]
>>>    API return code:            0x80BB0001 (VBOX_E_OBJECT_NOT_FOUND)
>>>    COM error info result code: 0x80BB0001
>>>    COM error info text:        Guest OS type '' is invalid
>>>    4: accepted connection from IP=127.0.0.1 socket=9... #### SOAP FAULT: 
>>> VirtualBox error: Guest OS type '' is invalid (0x80bb0001) 
>>> [SOAP-ENV:Client]
>>> [/code]
>>> ...
>>> Am I mistaken?
>>> THX
>>>     
>>
>> Klaus
>>
>> _______________________________________________
>> vbox-dev mailing list
>> vbox-dev at virtualbox.org
>> http://vbox.innotek.de/mailman/listinfo/vbox-dev
>>   
> Thank you Klaus,
> in the api, it's just said that the first parameter is ( after the 
> _this string ) is the VM's directory, the second is the VM's name and 
> the third is the UUID. The doc also suggest to let the directory and 
> the uuid empty. Only once you've get a machine's ref through
> this method call, you can specify the OS type and finally register the 
> newly created virtual machine...
> At the time this fault occurs, I'm not supposed to have supplied th OS 
> Type...
>
> J-Mi
Hello everyone
I'm still facing the same issue with vm creation...
Does anybody have a suggestion?
I'm wondering if I have to open a bug repport...

THX

J-Mi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.virtualbox.org/pipermail/vbox-dev/attachments/20090205/5ee623c8/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: jean-michel_guillaume.vcf
Type: text/x-vcard
Size: 309 bytes
Desc: not available
Url : http://www.virtualbox.org/pipermail/vbox-dev/attachments/20090205/5ee623c8/attachment-0001.vcf 


More information about the vbox-dev mailing list