[vbox-dev] building and running VirtualBox on Mac OS X

Knut St. Osmundsen bird at innotek.de
Mon Sep 3 07:02:44 PDT 2007


Egor Egorov wrote:
> 
> Hello! 
> 
> I'm trying to build VirtualBox from SVN on intel Mac OS X 10.4.10 with 
> last dev tools. I found the kLdr package "from month ago" and put the 
> source into src/VBox/Runtime/kLdr, I configure as: 
> 
> ./configure --disable-sdl-ttf 
> --with-gcc=/opt/local/bin/i386-elf-gcc-3.4.3 
>  --with-g++=/opt/local/bin/i386-elf-g++-3.4.3  --ose 

The gcc and g++ compilers you point configure to here aren't right. I 
guess that's because the gcc version check logic in configure didn't 
account for mac os x using gcc 4.0.x. That's been fixed now. So, running 
./configure without any arguments should work fine again.

> It builds, though, I had to tweak makefiles to omit non-existing darwin 
> installation and USB support, but it's minor.

I've fixed makefiles so that now tweaks should be necessary.

> Can you help me, why doesn't it run without "export 
> VBOX_SUPLIB_FAKE="fake"" ? I tried to load beta2 kernel extension - it 
> doesn't go; I tried to load the newly-built extension - it doesn't go. 
> Here's how I run it: 
> 
> egor2-ws:~/builds/vbox/out/darwin.x86/release/dist/VirtualBox.app/Contents/MacOS 
> egor$ ./VBoxBFE -hda ~/Library/VirtualBox/VDI/xp.vdi  -boot c -m 256 
> VirtualBox Simple SDL GUI built Sep  3 2007 11:19:17
> Unknown error creating VM (VERR_GENERAL_FAILURE)!
> VBox status code: -1 (VERR_GENERAL_FAILURE)
> Error: VM creation failed with VERR_GENERAL_FAILURE.

I've fixed this problem. The src/VBox/VMM/Makefile.kmk had an obsoleted 
VBOX_OSE hack. If you've loaded VBoxDrv.kext and checked out kLdr 
correctly, it should work now. The kext can be loaded using the load.sh 
script found in out/darwin.x86/release/dist. kLdr you can get by 
entering src/VBox/Runtime and typing:
   svn co http://svn.netlabs.org/repos/libc/trunk/kLdr@3523 kLdr

> Even with "fake" specified, it doesn't boot Windows; after the windows 
> splash screen, the virtualbox segfaults. Extensions installed.  Ubuntu 
> starts to boot, but very slow. Didnt' tested if it can finish the boot, 
> but kernel is working, that's for sure. 

The fake mode is very slow. It's not a priority (yet) to do anything 
about that as its only purpose it to serve as a milestone when porting 
VirtualBox to a new host OS.

Kind Regards,
  knut





More information about the vbox-dev mailing list