[vbox-dev] "Bug" on Virtualbox 1.5 with Via C7 CPU: Can't run XP guest

David Losada Gacio david.losadag at gmail.com
Sat Oct 13 13:07:26 PDT 2007


Yes, I'm capable and willing to do the necessary tests (I would like
to use Virtualdub instead of vmware althought it is a little slower;
it is open source). I haven't tried vmware yet on this machine; I
don't know if there is any way to know what CPUID/eax passes vmware to
the XP installer...

I will test to compile from svn now. Please let me know when you make
any change.

Thank you,

David

2007/10/13, Knut St. Osmundsen <bird at innotek.de>:
> David Losada Gacio wrote:
> > It was discovered in february this year as Heike C. Zimmerer wrote (see:
> > http://www.mail-archive.com/vbox-users@virtualbox.org/msg00423.html ),
> > but it's still a problem. When I install Win XP SP2 as guest on
> > Kubuntu 7.10 host with a C7 Esther processor it refuses to install.
> >
> > With my previous C3 Samuel without cmov Virtualbox 1.4 WinXP run
> > perfectly, but now with C7 (it's like a i686) I can't run it...
> >
>
> My hunch is that we're doing something wrong wrt to the
> CPUID/eax=0xc000000x and/or CPUID/eax=0x8000000x on those CPUs. I'll try
> google up some specs and see if I can't figure it out... Let me know if
> you're capable of building the trunk and willing to do some testing.
>
> Kind Regards,
>   knut
>
> _______________________________________________
> vbox-dev mailing list
> vbox-dev at virtualbox.org
> http://vbox.innotek.de/mailman/listinfo/vbox-dev
>




More information about the vbox-dev mailing list